Auto CAD Tutorial For Beginners Part 1

Auto CAD is the abbreviation of “Automatic Computer Aided Drafting”. It is the basic structural engineering software. It is an electronic tool that enables you to make quick and accurate drawings. It is used for the designing of buildings, highways, dams, bridges and all civil engineering structures. It is the simplest software with all the necessary elements and tabs used in structural designing. It can be easily understood by the beginners with a little practice. I am going to teach you autocad basics through this tutorial.

Installation of Autocad:

Step 1

Double click “setup.exe” file in Autocad folder. Here as sample I am showing Autocad 2004 and 2008 windows and tabs.


Step 2

Click next button as shown above.

Step 3

3. Check “I accept” and click “Next”.

Step 4

4. For serial number you can write 000-00000000 to activate your trial license or enter the serial number given on your autocad CD cover.

Step 5

5. Now click “Next” until installation starts.

Step 6

6. After installation click “Finish”.

7. Restart the computer if it asks so.

Step 7

8. Now double click the Crack folder and copy all the files.

Step 8

9. Paste these files into the autocad folder where the program is installed e.g C driveProgram FilesAutocad2004.

Step 9

10. Now run the Adesk file and click “yes”.

Step 10

11. Your program will be ready to work. Double click the following icon on your desktop to start using Auto cad.


Different Features of Auto cad:

1.Windows Drop Down Menu


2.Windows Tool Bar


3.Draw Tool Bar

This tool bar is at the left side of the window


4.Modify Tool Bar

This tool bar is at the right side of the window


5.View Tabs


These tabs give access to different views of the current drawing. The “model” tab should be selected at present.

6.Drawing Area

Complete black screen of GUI (Graphical User Interface)

7.Command Area


To write your commands there is space  for text.


The “status Area” at the bottom of the autocad window shows the current cursor position.



Horizontal Scroll Bar


Vertical Scroll Bar

Some Important Steps before Working on any Project:

Note: represents “Go To”

← represents “Enter”


Save your file by any of the following three methods:


Click10  from windows tool bar.


Select Filesave from the drop down menu.


Type QSAVE← in the command area.


Specify “Units” of your project. It defines Drawing Units, Length Precision, Angle Type, Angle Precision etc.

Type “UN” in the command area or select FormatUnits.

The following window will appear:


Set the parameters as following:



Specify “Drawing Limits” of your project. It defines the area of your drawing sheet where you work.

Type “Limits” in the command area or select FormatDrawing Limits.

Now set the limits by defining the co-ordinates in the command area e.g secify lower left corner (0’,0’) and upper right corner (80’,80’) for an area of 80 square feet.


“Zoom” your sheet by typing in the command area z←a. Now your drawing sheet will be displayed where you work.

Ways to give a command:

There are three ways to give a command.

  1. Select the command from tool bars.
  2. Type the command in the command area.
  3. Select the command from menu.

To exit from any command press “Esc” or “space bar” from your keyboard.

Commands used in Autocad:

1. Line Command:   


First tool in the draw tool bar is line. This is the most used tool while drawing any type of drawing.

Select Line from draw tool bar or type “L” in the command area and press enter. Specify first point of line e.g type (10’,10’). Press F8 to make ORTHO ON and the line will become straight. You can rotate line at 90 degree using this command. If you again press F8, it will make ORTHO OFF and the line can be rotated at any angle. A simple way is to specify the direction of desired line through cursor and at the same time type the length in the command area.

Zooming Options:

You can “Zoom In” or “Zoom Out” the objects in your sheet by mouse scroll bar or use “Zoom Real time” from tool bar.

Use “Pan Real time” from tool bar to move the whole object.

2. Offset: 


Offset command creates a new object whose shape parallels the shape of a selected object.

Select Offset from modify tool bar or type “O” in the command area and press enter. Specify offset distance e.g 3’ and select the line whose offset you need to draw. Then click on that side of  the line where offset is desired.

3. Trim :


You can remove cutting or projected edges of line with this command.

Select Trim from the modified toolbar or type “tr” and press enter enter (twice). Then click on cutting edge of the line which you want to erase.

4. Extend: 


You can extend line with this command.

Select Extend from modify tool bar or type “ex” in the command area and press enter enter (twice). Then click on the corner of the line which you want to extend.

Try to draw the plan of a single room with a window and a door which appears like this. This would be your first practice.


When you select a line, blue points appear at the centre, start and at end.

When you make window from left to right during selection of objects  then the objects which are complete in window will be selected and which are incomplete in window will not be selected.

When we make window from right to left during selection of objects then the objects which are either complete or complete in window will be selected.

Space button also serves as enter button.

5. Osnap:

To locate the midpoint, starting point, end point and intersection point of lines osnap is made on by pressing F3.

Go to from menu bar Tools→Drafting Settings and select osnap tab. Here you can mark the desired points of lines and unmark the undesired ones.

When you go to any line, endpoints are shown by small rectangles whereas midpoints are shown by small triangles. Intersection points are shown by small cross.

6. Copy: 


Select Copy from modify tool bar or type “co” and press enter.

Specify base point from where you want to move other copied object (If you want to copy just once).

For multiple copies type “m”.

7. Move :


Select Move from modify tool bar or type “m” and press enter.

Select object which you want to move. Specify base point from where you want to move the object. Click at the point where you want to move the object.

8. Edit:

Type “ed” and press enter.

Select object and press enter.

Rename the object name.

Click ok and then escape the command.



Go to from menu bar: Format→Text style or type “st”, a dialog box will appear.

Click New Tab, type Style Name, select Font Name, Select Font Style, Height of Text, Apply and close the dialog box.

Go to from menu bar: Draw→Text (single line or multi line text) or type “dt” for single line and “mt” for mutliline text. Then type any word you want.

Guys this is all for now. I am sure this tutorial will help you a lot in learning the basics of Auto CAD. Further if you need my help for learning other commands, do tell me. I’ll be there for you. Good Luck!



  1. By Suleman Anthony Gill


  2. Reply

Leave a Reply

Your email address will not be published. Required fields are marked *