How to make a model using etabs?

Introduction to Etabs:

Etabs is a very useful software in the field of civil engineering. It is the most used software in structural engineering for the design of buildings, bridges and more complex analytical models. It features a powerful graphical user interface. It is used for linear, non-linear, static and dynamic analysis and design of the building systems. Etabs is best for designing of simple 2D frames as well as performing a dynamic analysis of complex high-rise structures and shear walled buildings.

Using etabs you can:

1. Create and modify a model

2. Exectue the analysis

3. Design a model as well as optimize the design

4. It displays results in graphical forms and also display real time-history displacements and generate reports.

How to Install etabs:

The installation procedure for Etabs is quite simple as compared to other structural engineering softwares, you don’t have to remember a number of steps to install and crack the software. Just follow these simple steps:

1. First of all double click the “setup.exe” file from the Etabs setup folder or CD.

2. When the installation is complete, run the “Etabspatch.exe” file.

3. Now double click the following icon on your desktop.

etabs

The program will work.

Here for sample I am using the version Etabsv9.7.1 (non-linear). All the tabs and windows shown in this tutorial are from this version.

When you open Etabs for the first time, it gives you “Tip of the Day”. Etabs gives you useful tips regarding the use of software.

etabs

You can uncheck the box at the bottom if you do not wish to receive these tips. However I recommend you to check the box.

Different Features of etabs:

1. Windows Drop Down Menu

etabs

2. Windows Tool Bar

etabs

3. Complete black screen of Graphical User Interface.

4. Command Tool Bar

etabs

5. Etabs gives you three views of your model (Plan, Elevation or 3D)  etabs and also the extruded view (click etabs and check the box “extrusion” and “object  fill” and then click apply to all windows)

6. Model can be rotated in 3D using this tab etabs.

7. By clicking this tab   repeatedly, you will be shown different sides of the 3D model or the plan one by one etabs.

8. There are the too many zooming options. etabs First one is for Rubber band zoom,second to Restore full view, third to Restore Previous zoom, fourth to zoom in one step and last is to zoom out one step.

9. Whichever section you want to select for a particular task e.g Replication, just go to Selectframe section or wall/slab/deck section or any one of your choice, only those section will be selected in your whole model.

Here I am going to teach you the steps for making any model in etabs. At the end you will realize how easy it was.

First step is to click on FileNew Model

etabs

A dialog box will appear.

etabs

Click on Default.edb. Now another box appears.

etabs

Click on Custom Grid and then on Edit Grid. A new box appears.

etabs

Here enter all the X and Y Co-ordinates i.e the co-ordinates of plan according to the autocad drawing of the structure and click Ok. Now click on Custom Storey Data to enter the co-ordinates of Z-axis i.e elevation in the same way and click Ok. Then select your units. I have hosen Kip-ft. In the Add Structural Object tab, choose Grid Only. Click Ok. Now your grid will be displayed on screen.

Second Step is to Define the Material Properties i.e define the materials used/planned to be used in your structure. Click DefineMaterial Properties.

etabs

The following dialog box will appear.

etabs

Click on Add new Material. However Concrete and Steel are already defined by default. For them you can click on Modify/Show Material and set your desired properties e.g color, poisson’s ratio, coefficient of thermal expansion, shear modulus etc.

etabs

 

Third Step is to define the Frame Sections. Here you will define the beams and columns you have used or proposed for the building. Click on DefineFrame Sections

etabs

Now click on Add Rectangular.

etabs

Another dialog box will appear.

Type the name of the frame section e.g Beam, Column. and write down the dimensions of the beam or column.

etabs

Now click on Concrete Reinforcement and in the following dialog box select Beam for beams otherwise Column is already selected by default.

etabs

Then click “Ok” and close the dialog boxes.

Fourth step is to define the Area or Shear Wall sections. Go to Define→Wall/Slab/Deck sections.

etabs

This window appears.

etabs

Click on modify if your desired area section has been already defined or click add new slab or wall or deck.

etabs

Type the section name, material, thickness (membrane and bending) and Type. Then click Ok. Note that you will write the value of bending which is membrane thickness minus one inch.

Fifth Step is to define the loads. Go to DefineStatic Load cases.

etabs

etabs

Dead and Live loads are already defined. Add other loads by writing their names one by one in Load and choose their type. For Example I have written SDEAD for Super Imposed Dead Load, and chosen the type Super Dead. Also define Earthquake Loads in X and Y directions. For them select auto lateral load according to the code you are following. I have chosen UBC 97. Now highlight the quake loads one by one and click on Modify Lateral Load. The following box will appear.

etabs

Here you can provide info about direction of earthquake, soil type, earthquake zone, time period, importance factor and overstrength factor. Set the parameters according to your structure. Click Ok to close the dialog boxes.

Sixth Step is to define Load Combinations. Go to Define→Load Combinations.

etabs

This window appears.

etabs

Click on Add New Combination.

Choose the load combination type. For ACI combinations you will choose Add.

etabs

You can also choose the default combinations already defined in the software. Go to Define→Add Default Design Combos and select according to your structure.

Seventh step is to defne Mass Source. Go to Define→Mass Source.

etabs

Choose From Loads and enter all the dead loads you have defined in the static load cases. Click Ok.

etabs

Now all the data have been added and now you have to place Beams, Columns and Slab (and shear wall). you can move up and down in each story of the building with the help of these tabs etabs.

For a symmetric building, i.e if beams, columns, slabs etc are placed at same locations in each story then you do not have to place beams, columns, slabs etc manually one by one in each story. You can “Replicate” by making window (in window the beams should b selected) and click on Edit→Replicate. The following window appear.

etabs

You can enter the required amount of replication.

etabs

 

Eighth Step is to draw the line elements i.e beams.

etabs

Click etabs  on the command tool bar and the following box appears.

etabs

Now place the beams in the plan with the help of pointer according to the autocad drawing you are following.

etabs

Next draw the Columns.

etabs

Click on etabs  on the command tool bar and place columns either in plan or in elevation.

etabs

Now place the slabs in the plan. Click on etabs on the command tool bar.

etabs

The following window appears.

etabs

The slab should be drawn by clicking once in the slab regions or also by selecting Draw Areas option from command tool bar, click one by one on the corner points in an anti-clockwise pattern and then press enter. Slab will be shown in gray color (if you have chosen ‘objects fill” discussed in the start).

etabs

Now your model is almost complete.

Nineth step is to provide joint restraints. Select the column foundations (in the Basement) by making window and go to Assign→Joint/Point→Restraints/Supports.

etabs

The following window appears.

etabs

Choose Fixed in Fast restraints and click Ok.

Tenth step is to mesh the areas. Go to Select and click on Wall/Slab/Deck areas and then choose slab. Slabs of whole model will be selected. Now go to Edit→Mesh Areas

etabs

This window appears. Division of areas into 2×2 is reasonable. Click Ok.

etabs

Then provide End Length Offsets to all the beams and columns. For this go to Select→By Frame Sections and select the beams and columns you have used in your model by holding “Ctrl” button on the keyboard.

Then go to Assign→Frame/Line→End(Length)Offsets.

etabs

This window appears. Click on Automatic from Connectivity and click Ok.

etabs

Now assign the loads one by one to the areas. Make selection of slabs of the whole model in the same way as described earlier and then go to Assign→Area/Slab Loads

etabs

This window appears. Enter the loads magnitudes.

etabs

In the same way assign all the loads one by one.

Here comes the last step, Run the Analysis.

etabs

A report will be generated. Play the animation to see the vibrations of your model under the action of different loads one by one. Find out the faults in your model. etabsusing this tab, click Start Design Check of Structure. Check from the analysis results which of the elements in your model tend to fail. To fix them, unlock your model and again go to Define Frame Sections and modify them i.e increase their sizes. Then run the analysis again. Your model should be having optimize sections.

etabs

These tabs will show you the undeformed, deformed shapes, Mode shape and member/forces stress diagram.

You can see the rendered view by clicking on View→Create OpenGL View

etabs

That was all about etabs. If you further need any guidance or have queries, do tell me, I will help you. Keep on practicing and you will explore more and more in this software. Good Luck!!

Advertisement

Comments

  1. By Wadud

    Reply

    • Reply

    • By zain

      Reply

  2. By AVINASH

    Reply

    • Reply

  3. By Wadud

    Reply

  4. By SEILm

    Reply

    • Reply

      • By mureed abbas

        Reply

      • By mureed abbas

        Reply

  5. By eeeDesign

    Reply

  6. By GOURAV THAKUR

    Reply

  7. By zain

    Reply

  8. By zain

    Reply

  9. By juni

    Reply

  10. By shirish

    Reply

  11. By waqas iqbal

    Reply

  12. By bangash

    Reply

  13. By Konstantinos Sachpazis

    Reply

  14. By randa

    Reply

  15. By mani anand

    Reply

  16. By pretty anna kuriakose

    Reply

  17. By Syed Owais Ahmed

    Reply

  18. By musitefa

    Reply

    • By musitefa

      Reply

  19. By kennedy

    Reply

  20. By naeem

    Reply

  21. By cadouri

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *